Close

Library

Chyba ohrozuje tisíce linuxových aplikácií a takmer všetky distribúcie Linuxu

Kritická chyba bola objavená v GNU C Library (glibc), čo je kľúčový prvok väčšiny linuxových distribúcií. Jej vinou sú takmer všetky linuxové stroje, tisícky aplikácií a zariadení zraniteľné hackermi, ktorí môžu prevziať úplnú kontrolu nad nimi. Jednoduché kliknutie na odkaz alebo pripojenie k serveru môže viesť k vzdialenému spusteniu kódu (remote code execution – RCE), čo umožní hackerom ukradnúť prihlasovacie údaje, špehovať používateľa, získať kontrolu nad počítačom a pod. Zraniteľnosť je podobná minuloročnej chybe GHOST (CVE-2015-0235), ktorá vystavila množstvo zariadení hrozbe útokov RCE. GNU C Library (glibc) je štandardná knižnica jazyka C predovšetkým v linuxových systémoch. Chyba bola indexovaná ako CVE-2015-7547 a spustí sa, keď funkcia knižnice […]